Debian derivatives (including Ubuntu)

If you are running a Debian derived distribution, such as Ubuntu, there are various options for you. One of the easiest is to use the Monkeysphere Apt repository to get all the pieces directly.

To get started using the Monkeysphere for website validation, you will also need to install the Monkeysphere Validation Agent. Currently the perl version of the agent is only available directly from our repository. Once you have installed the monkeysphere package, you will need to also install the validation agent.

Ubuntu "Lucid Lynx"

Ubuntu users running "Lucid Lynx" (10.04) can currently obtain the monkeysphere from the standard Ubuntu universe repository. If you would like a newer version, you should get it directly from the Monkeysphere Apt repository.

To obtain the Monkeysphere Validation Agent (for website validation), you will need to get msva-perl from our repository.

Ubuntu "Karmic Koala"

Ubuntu users running "Karmic Koala" (9.10) should see version 0.26-1 in the standard Ubuntu universe repository. If you would like a newer version, you should get it directly from the Monkeysphere Apt repository.

To obtain the Monkeysphere Validation Agent (for website validation), you will need to get msva-perl from our repository.

Ubuntu "Jaunty Jackalope"

Ubuntu shipped Monkeysphere 0.22 in their "Jaunty Jackalope" release (9.04). The Monkeysphere developers think that Ubuntu shipping Monkeysphere 0.22-1 is a bad idea. If you are running Ubuntu "Jaunty", we would prefer that you install directly from the Monkeysphere Apt repository rather than run 0.22, which we no longer consider supported.

To obtain the Monkeysphere Validation Agent (for website validation), you will need to get msva-perl from our repository.